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Introduction 
This tutorial will take you through the process of using the RoboJDE Java -
enabled robotics software development environment to create, build, load and 
run your first Java program on the IntelliBrain

 
robotics controller. 

Before Getting Started 
Before getting started, take a few minutes to locate and familiarize yourself with 
the IntelliBrain User Guide and the RoboJDE User Guide.  These documents can 
be found in the docs folder on the Software and Documentation CDROM that 
came with your IntelliBrain robotics controller.  The most up-to-date versions of 
these documents may also be obtained from the RidgeSoft  website 
(www.ridgesoft.com).  

If you purchased an IntelliBrain-Bot educational robot kit, assemble the robot first 
following the instructions in the IntelliBrain-Bot Assembly Guide before beginning 
this tutorial.  

If you purchased only the IntelliBrain robotics controller, consult the IntelliBrain 
User Guide for information on assembly, powering and mounting the controller 
on your robot chassis. 

Installing and Configuring RoboJDE 
If you have not already installed and configured RoboJDE, follow the steps in this 
section, otherwise you may skip this section.  

Installing the RoboJDE Software  

1. Insert the CDROM that came with your IntelliBrain robotics controller into 
your PC s CDROM drive.  The installation program should start 
automatically.  

2. If the installation program did not start automatically, start it from the 
Windows Start Menu by selecting Start->Run then browsing to and 
selecting RoboJDESetup.exe on the CDROM.  

3. Follow the directions provided by the installation program.  

4. Before removing the CDROM, browse the docs folder to familiarize 
yourself with the documents that have been provided on the CDROM in 
addition to the RoboJDE software.  If you would like a copy of the 
documents on your PC s hard disk, copy the files to a folder on your PC s 
hard disk.  
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Connecting the IntelliBrain Controller to Your PC  

RoboJDE communicates with the IntelliBrain robotics controller via a serial port 
on your PC.  You must connect the PC serial port to your IntelliBrain robotics 
controller using a straight through serial cable.  The IntelliBrain-Bot kit includes a 
serial cable.  

1. Attach the male end of the cable to the host port connector, labeled 
COM1, on the IntelliBrain robotics controller.  

2. Attach the female end of the cable to a COM port on your PC, noting the 
number of the port you used.  If your PC has USB ports, but not serial 
ports, you will need to first install a USB to serial adapter cable, such as 
the IOGear GUC232A.  

Starting the RoboJDE Graphical User Interface  

1. Using the Windows Start Menu, start RoboJDE.  

2. Read the license agreement and, if you agree to its terms, select the 
agree option and click Continue.  

Installing Your License Key  

RoboJDE requires a license key to unlock its full functionality.  A license key is 
included with the purchase of each IntelliBrain robotics controller and each 
IntelliBrain-Bot robot kit.  You must install the license key; otherwise, the 
capabilities of RoboJDE will be limited.  

1. Locate the license key label on the back of the CDROM case.  

2. Select the Tools->License Key menu item to display the Install License 
Key dialog.  

3. Type the key printed on the label into the dialog, being careful to enter the 
hyphens, letters and numbers correctly.  Note:  License keys contain only 
the numbers 0-9 and the letters A-F and do not contain the letter O .  

4. Click OK.  

Configuring RoboJDE Settings  

1. Use the RoboJDE Tools->Settings menu item to display the Settings 
dialog box.  
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2. Set the Board Type to IntelliBrain.

  
3. Set the Serial Port setting to the name of the PC serial port to which you 

connected your IntelliBrain controller.  

4. Set the Baud Rate to match the baud rate configured on your IntelliBrain 
controller.  The default is 38400.  To change to different baud rate, or view 
the currently configured baud rate, see the IntelliBrain User Guide.  

5. Click OK.  

Verifying Communication between your PC and the IntelliBrain Controller  

At this point, if everything is configured properly and the serial cable is 
connected, the RoboJDE GUI should be able to communicate with the IntelliBrain 
controller.  

1. If you have not already connected the battery back to your IntelliBrain 
controller, do so now, attaching the red lead to the red terminal on the 
power terminal block and the black lead to the black terminal.  

2. Insert fresh batteries in the battery pack, being careful to install the in the 
proper orientation.  

3. Power the IntelliBrain controller on by sliding the power switch lever in the 
direction of the LCD display. The green power LED should turn on.  The 
red fault LED should blink once and the RoboJDE should version number 
on the LCD display.  If this doesn t happen, ensure that you have installed 
good batteries in the battery pack and that you have installed them in the 
proper orientation.  

4. In the RoboJDE GUI, click on the Run tab near lower left corner of the 
window if it is not already active.  

5. The VM State field should display Load or Ready and numeric values 
should display in the Threads , Objects , Free Blocks and Free Bytes 
fields.  If this doesn t occur, check that the serial cable is connected and 
the selections you made in the RoboJDE settings dialog are correct.  

6. Check the RoboJDE version numbers by selecting the Help->About menu 
item.    

7. If the version of the RoboJDE virtual machine does not correspond to the 
version of the user interface version, use the Tools->Download Virtual 
Machine menu item to download the virtual machine.  At the time of this 
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writing, the user interface version number was 1.3.1 and the virtual 
machine version number was 1.3.0. 

Creating Your Own Robotics Software Project 
RoboJDE uses project files to make it easy for you to switch between different 
projects you may be working on.  Use the following procedure to create a project 
titled MyBot :  

1. Select File->New Project menu item in the RoboJDE GUI.  The Project 
Properties dialog will appear.  

2. Click the browse button to the right of the project folder field.  Browse to 
and select the folder you want to create the new project in.  

Note:  You can create a new folder by browsing to where you want to 
create the folder then pressing the create folder button.  A folder titled 
New Folder will appear.  Click on its name to change the name to a 

name you choose, then click on the folder icon to the left of the name and 
click OK.  

3. Enter the name MyBot in the Main class field.  

4. Click OK.  The MyBot class will be created, as shown in Figure 1.  

 

Figure 1 - MyBot Project in RoboJDE  
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5. Click the Save all button (see Figure 2) or select the File->Save All menu 
item.  The Save dialog will appear with MyBot as the proposed file name.  

Figure 2 - RoboJDE Tool Bar  

6. Click the Save button to save your project.  

Building, Loading and Running Your Program  

The MyBot program, shown in Figure 1, is currently just a stub program that does 
nothing.  Never-the-less, you can build it, download it and run it on the IntelliBrain 
controller.  Follow the steps below to build, load and run the MyBot program:  

1. Switch the IntelliBrain controller s power switch to the on position.  The 
Download button on the RoboJDE tool bar (see Figure 2) will become 
enabled, changing color from grey to green, indicating the controller is 
communicating with the RoboJDE GUI.  

2. Click the Download button to build the MyBot program and download it to 
the IntelliBrain controller.  

Note:  You can choose to load the application to the RAM or FLASH 
memory by changing the load location on the tool bar.  While developing 
your program it is faster and easier to load the program into RAM.  
However, the program will not be retained when you turn the IntelliBrain 
controller off.  Downloading the program to FLASH memory will allow it to 
be retained when you turn power off.  

3. Click the Run button on the RoboJDE tool bar to run the MyBot program.  

The MyBot program is currently only a stub program that does nothing 
other than start and then immediately exit.  After pressing the run button, 
you will notice the state Running displayed briefly on the IntelliBrain LCD 
screen and in the VM State field in RoboJDE Run window.  RoboJDE 
automatically switches to displaying the Run window when you click on 
the Run button.  
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Note:  You can also run a program by pressing the button labeled 
START on the IntelliBrain controller.  

4. Press the START  button on the IntelliBrain controller to run the MyBot 
program again.  

Outputting Text to the LCD Screen  

Now that you ve created and run your first program, you re probably eager to 
have the program actually do something!  Use the following steps, to modify the 
program to print MyBot on the first line of the LCD screen and Version 0.1 on 
the second line:  

1. If the Edit window isn t currently displayed in RoboJDE, click on the Edit 
tab in the lower left corner of the RoboJDE window.  

2. Use the Edit window to modify the MyBot program to contain the following 
code:  

import com.ridgesoft.io.Display; 
import com.ridgesoft.intellibrain.IntelliBrain;  

public class MyBot { 
    public static void main(String args[]) { 
        try { 
            Display display = IntelliBrain.getLcdDisplay(); 
            display.print(0, "MyBot"); 
            display.print(1, "Version 0.1");  

            Thread.sleep(5000);  
       } 

        catch (Throwable t) { 
            t.printStackTrace(); 
        } 
    } 
}  

If you are familiar with Java, these code changes will be easy to 
understand.  If you are not very familiar with Java, the following 
paragraphs give a brief explanation of this example.   

The first two lines add import statements to import the Display class and 
the IntelliBrain class from the RoboJDE class library.  This allows you to 
use these classes later in the program.  

The try and catch statements allow the program to catch any exceptions 
or errors that occur while the program runs.  The t.printStackTrace method 
call in the catch code block will print out detailed tracing information that 
will help you debug unexpected exceptions or errors.  The stack trace 
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output will be displayed in the RoboJDE Run window if the robot is 
connected to the host PC.  

The IntelliBrain.getLcdDisplay method call gets a reference to the Display 
object for the IntelliBrain s LCD display.    

Tip:  The IntelliBrain class provides methods that enable your programs to 
access the features of the IntelliBrain controller.  When you want to use a 
feature of the IntelliBrain controller that you haven t used before, refer to 
the IntelliBrain User Guide for basic examples of accessing various 
features of the controller.  For more in-depth information, refer to the 
RoboJDE Class Library API documentation.  The documentation for the 
IntelliBrain class is typically a good place to start.  Click on the blue book 
icon on the RoboJDE tool bar (see Figure 2) to display the API 
documentation.   

The two display.print method calls print text to line 0 and line 1 of the LCD 
display.  

The Thread.sleep method call causes the program to sleep for 5000 
milliseconds (5 seconds) before returning and continuing.  The program 
terminates after this call.  

3. Switch the IntelliBrain controller s power on.  

4. Click the Download button to build and load the program.  

If you made any errors typing the code, the Java compiler will report an 
error in the lower pane of the Edit window.  Correct any errors and repeat 
this step until the program compiles and downloads.  

5. Click the Run button.  

The MyBot program will run and display:  

MyBot 
Version 0.1  

for 5 seconds, before exiting. 

Conclusion 
Now that you have completed this tutorial, you should be familiar with using 
RoboJDE to: 1) create a robotics software project, 2) build and download a 
program to the IntelliBrain robotics controller and 3) run the program. 
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Exercises  

1. Modify the MyBot program to display your name instead of MyBot.

 
2. Download your program to FLASH memory.  Verify that you can run the 

program without reloading it after you have turned the power off and back 
on. 

3. Click on the User Guide button on the RoboJDE tool bar.  Browse the 
RoboJDE User Guide. 

4. Click on the API documentation button on the RoboJDE tool bar.  Find the 
IntelliBrain class, the Display class, the Thread class and the Throwable 
class in the classes list located on the left. 

5. Navigate through the API documentation to the documentation for the 
getLcdDisplay method in the IntelliBrain class. 

6. Navigate through the API documentation to the documentation for the print 
method in the Display class. 

7. Navigate through the API documentation to the documentation for the 
sleep method documentation in the Thread class. 

8. Navigate through the API documentation to the documentation for the 
sleep method documentation in the Thread class. 

9. Navigate through the API documentation to the documentation for the 
printStackTrace method documentation in the Throwable class. 

10. Find and read the documentation on using the LCD display in the 
IntelliBrain User Guide. 

11. Find the references to using the LCD display on the IntelliBrain API quick 
reference card ( IntelliBrainAPI.pdf in docs folder on the CDROM).  

12. Display the RoboJDE User Guide by clicking on the appropriate button on 
the tool bar.              
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